Economics 471: Econometrics
Department of Economics, Finance and Legal Studies
University of Alabama
Course Packet
The purpose of this packet is to show you one particular dataset and how it is used in practice
with the methods taught in lecture. The data used in the packet are available on the course
website
https://dhenderson.people.ua.edu/uploads/1/2/3/4/123460056/1600.xls
A brief description of the variables is available on the course website
https://dhenderson.people.ua.edu/uploads/1/2/3/4/123460056/eh3733_des.pdf
You should be able to replicate all of the results using the econometric package, Gretl
(http://gretl.sourceforge.net/). This should help bridge the material from class with the computer
program and at the same time help you with the assigned problem sets. Brief explanations on
how to obtain the various tables and figures within the Gretl window framework are given within
the packet.
The academic paper from which this subset of data was collected can be found at
http://dx.doi.org/10.1111/j.1368-423X.2008.00244.x
You are not required to read or understand the material in the paper, but you may be interested in
the motivation for choosing this particular data. You must be on campus to access the
information in the above link. A related paper of interest is here:
http://dx.doi.org/10.1016/j.econedurev.2011.03.011
This packet is designed to be a tool which will help you understand the difficult material in the
course. You are expected to bring this to each lecture as I will often refer to the results given in
the packet. Questions, comments and suggestions are always appreciated.

Descriptive Statistics
Sample Average

Sample Standard Deviation

y

y

Gretl Steps:
View → Summary Sta s cs → Include: testscores, homework, hrsofclass, classsize, and
prevtestscores → Ok → Show full statistics → Ok

Conditional Expectation

|

testscores if sex=0 = 52.896
testscores if sex=1 = 52.003
Interpretation: Tenth grade boys (sex=0) scored higher, on average, than 10th grade girls
Gretl Steps:
Click on testscores → Sample → Restrict, based on criteria → Enter boolean condi on for
selection cases: sex=0
After observations are dropped, right click on testscores → summary sta s cs
Then, click on testscores → Sample → Restore full range and repeat for sex=1

Sample Covariance

Sample covariance between homework and testscores = 0.617928
Gretl Steps:
Open new script (in bottom “ribbon”, second from left) → enter code: q1_d=
cov(testscores,homework) → highlight and run (control+R)

Sample Correlation Coefficient

Interpretation: Both the covariance and correlation measure the linear dependence between the
variables.

Gretl Steps:
Select testscores and homework → right click → Correla on matrix

Histograms, PDFs, and CDFs
Histogram

Gretl Steps:
Right click on testscores → Frequency distribu on → Change Number of Bins to the desired
number of “blocks” (in this case, 17) → Ok

Probability Density Function (pdf)

Gretl Steps:
Select testscores → Variable → Estimated density plot → Gaussian kernel with bandwidth
adjustment factor = 1.06 → Ok

Cumulative Distribution Function (CDF)

Gretl Steps:
From PDF output box →Save interval midpoint and the cumula ve frequency as new variables
→ View → Graph Specified Vars → X‐Y Scatter → X‐Axis: interval, Y‐Axis: cumulative frequency
→ Ok → Edit → Lines → Change Points to Lines

Simple Linear Regression Model (Regression of y on x)

Interpretation: The constant, 49.8379, indicates that if a student does no homework, they would
earn an expected score of 49.8379 on the test. The homework coefficient indicates that each
additional hour of homework increases the expected test score by 4.01135 points.
Gretl Steps:
Model→ Dependent Variable: testscores → Regressors: const, homework → Ok

Plot

Gretl Steps:
In previous model “dialog box” → Graphs → Fi ed, actual plot → Against homework

Standard Error of

The standard error for the slope parameter is .393603.

Standard Error of Regression (SER)

The Standard Error of Regression, which is 9.437423, estimates the standard deviation in y after
the effect of x has been accounted for.

Sum Squared Residuals (SSR)

The sum squared residuals, which is 332301.3, measures the unexplained variation between the
data and the predicted values.

Explained Sum of Squares (SSE)

The explained sum of squares measures the explained variation between the predicted values and
the mean.

Total Sum of Squares (SST)

The total sum of squares measures the total variation in y. It is the sum of the explained and
unexplained variation.

R-Squared

R-squared, which is .027084, measures the proportion of sample variation in the dependent
variable that is accounted for by the independent variable(s) in the model. This value never
decreases, and usually increases, when adding more regressors.

Adjusted R-Squared

The adjusted R-squared, which is .026823, is similar to R-squared, but imposes a penalty for
adding more dependent variables.

Regression through the Origin

Interpretation: This model is used if we have reason to believe that the intercept is 0, e.g., if a
student does no homework, then they would earn a 0 on the test. Because the coefficient for
homework is 60.3, this indicates that each additional hour of homework boosts their expected

test score by 60.3 points. R-squared is meaningless when the intercept is excluded from the
model.
Gretl Steps:
Model → Ordinary Least Squares → Dependent variable: testscores, Regressors: homework
(const is NOT included) → Ok
For graph:
Tools → Plot a Curve → formula: y=60.3017*x → x range = 5 → Ok

Functional Forms with Logs

Level-Log

Interpretation: A one percent increase in class size increases expected test scores by 0.0274231
points.

Gretl Steps:
To create the new variable:
Right click on home screen → Define new variable → logclasssize=ln(classsize) → Ok
To create the model:
Model → Ordinary Least Squares → Dependent variable: testscores, Regressors: const,
logclasssize → Ok

Log-Level

Interpretation: Each additional student added to a class will increase expected test scores by
.2198%, which represents the semi-elasticity of test scores with respect to class size.
Gretl Steps:
Right click → Define new variable → logtestscores=ln(testscores) → Ok → Model → Ordinary
Least Squares → Dependent variable: logtestscores, Regressors: const, classsize → Ok

Log-Log

Interpretation: A one percent increase in class size will increase expected test scores by .059%.
This can be interpreted as the elasticity of test scores with respect to class size.
Gretl Steps:
Right click → Define new variable → logclasssize=ln(classsize) → Ok
Right click → Define new variable → logtestscores=ln(testscores) → Ok
Model → Ordinary Least Squares → Dependent Variable: logtestscores, Regressors: const,
logclasssize

Multiple Regression

Interpretation: With 0 hours of homework, a class size of 0, and 0 hours of class, a student would
be expected to score a 48.9805 on their test. Holding all else constant, each addition hour of
homework would increase their expected test score by 3.94193 points, each additional one-unit
increase in class size will increase their expected test score by 0.0947537 points, and each
additional one-unit increase in hours of class will lower their expected test score by 0.327947
points.
Gretl Steps:
Model → Ordinary Least Squares → Dependent Variable: testscores, Regressors: const,
homework, classsize, hrsofclass → Ok

Standard Error of

Quadratic Model

Interpretation: A curve that is concave down (e.g., has a negative square term) shows a
relationship where each additional hour of homework continues to increase a student’s expected
test score up to a certain point, at which each additional hour of homework will actually lower
their expected test score.

Gretl Steps:
Right click → Define new variable →homeworksq=(homework)^2
Model → Ordinary Least Squares → Dependent variable: testscores, Regressors: const,
homework, homeworksq → Ok

Plot

Gretl Steps:
In previous model “dialog box” → Graphs → Fi ed, actual plot → Against homework

Turning Point

Interpretation: The turning point represents the point at which the return to homework begins to
diminish. For this data, if we restrict the sample to students who do more than 2.8176 hours of
homework per day, there are only 17 sample points (out of 3733 total observations).

Standardized Beta Coefficients

Interpretation: For this regression, a one standard deviation increase in homework will result in a
.1617 standard deviation increase in test scores, a one standard deviation increase in hours of
class will result in a .034 standard deviation decrease in test scores, and a one standard deviation
increase in class size will lead to a 0.00389 standard deviation increase in test scores.
Additionally, the magnitude of the coefficients suggests which variable has the highest input. In
this case, homework has the largest impact out of the three regressors on test scores.

Gretl Steps:
Right click → Define new variable →zhomework=(homework‐mean(homework))/sd(homework)
→ Repeat for zhrsofclass, zclasssize
Model → Ordinary Least Squares → Dependent variable: ztestscores, Regressors: const,
zhomework, zhrsofclass, zclasssize → Ok

Lagged Dependent Variable Model

Interpretation: Including past test scores (from 8th grade) may help control for unobserved
variables that may influence test scores in the 10th grade, such as ability or school quality.
According to this model, increasing homework time by one hour will lead to a .88 point increase
in expected test scores, while scoring one point higher on a test in 8th grade leads to a .83 point
increase in expected test scores in 10th grade.
Gretl Steps:
Model → Ordinary Least Squares → Dependent Variable: testscores, Regressors: const,
homework, prevtestscores

Dummy Variable Models

Interpretation: The base group is male 10th graders. Being female will lower your expected test
score by 0.998 points for any value of homework.
Gretl Steps:
Model → Ordinary Least Squares → Dependent Variable: testscores, Regressors: const,
homework, sex

Plot

Interpretation: This model contains 3 dummy variables, two of which are binary (sex and
teachersex) and one with 7 groups (mother’s education level). The base group for this model is a
male tenth grader whose mother did not finish high school and currently has a male teacher (e.g.,
sex=0, teachersex=0, and mothereduc=1. The only different between the base group and the
alternatives is the intercept.
The students with the highest expected test scores are 10th grade boys whose mothers have a
masters degree and have a male teacher. The students with the lowest predicted test scores are
10th grade girls whose mothers dropped out of high school and currently have a female teacher.
The difference between the predicted test scores of these two groups for any given level of
homework is 11.532 points.
Gretl Steps:
Add → Dummies for Discrete Variables → mothereduc → encode all values → Model →
Ordinary Least Squares → Dependent Variable: testscores, Regressors: const, homework, sex,
teachersex, Dmothereduc_2, … ,Dmothereduc_7

Dummy Model with Interaction Terms

Interpretation: There is a clear slope change and a relatively small change in the intercept. The
expected return to homework is less for tenth grade girls than boys at all time periods spent on
homework, except when hours spent on homework is very small.
Gretl Steps:
Right click → Define new variable →hwrkandsex=homework*sex→ Model → Ordinary Least
Squares → Dependent variable: testscores, Regressors: const, homework, hwrkandsex, sex →
Ok

Confidence Intervals

Interpretation: The confidence interval for each variable indicates that we have 95% confidence
that the true population parameter is in this interval.
Gretl Steps
Model → Ordinary Least Squares → Dependent Variable: testscores, Regressors: const,
homework, classsize, hrsofclass → Ok
In Model Output Box → Analysis → Confidence intervals for coeﬃcients

T-test
OLS Model for test scores vs homework

For Beta:
t=10.19 → reject the null
Interpretation: The p-value of 0.000 indicates that we can reject the null hypothesis with nearly
100% certainty. Additionally, the critical value for 99% confidence is t = 2.576, which the test
statistic of t = 10.19 far exceeds.

For alpha:
t=167.2 → reject the null
Interpretation: The p-value of 4.47 x 10^-27 indicates that we can reject the null hypothesis with
nearly 100% certainty. Additionally, the critical value for 99% confidence is t = 2.576, which the
test statistic of t = 167.2 exceeds.

Testing Linear Combination of Parameters (Optional)
Single Restriction

Interpretation: This method bypasses the need to compute the covariance between
and We
can apply these values to the original hypothesis test. The critical value from the t-distribution at
a 99% confidence level in a one-tailed test is 2.326. With this specific test, we reject the null
hypothesis when the t-statistic is greater than the absolute value of the critical value. Since the tstatistic, 9.750, is greater than 2.326, we reject the null hypothesis.

Gretl Steps:
Define New Variable → hwrkclasssize=homework+classsize → Ok
Model → Ordinary Least Squares → Dependent Variable: testscores; Regressors: const,
homework, hwrkclasssize, hrsofclass → Ok

F-Test (Testing the Validity of the Regression)

value is zero for
In the case where the restricted model does not have a slope parameter, the
the restricted model. We can also compute the F-statistic using the following equation:

The F-statistic is greater than the critical value. Therefore, we reject the null hypothesis. At least
one of the parameters is different than 0. We can conclude by saying that the inclusion of
homework, class size, and hours of class explain some variation in the test scores.

is different from zero, or
In this test, we come to the same conclusion as before. Either or
and
are different from 0. Thus, the inclusion of class size and hours of class help explain
some variation in test scores.

Notes: when there is only one restriction, the F-statistic is the square of the t-statistic (10.19).
We reject the null hypothesis in this test as well. However, only this test tells us that homework
is statistically significant. The inclusion of homework helps explain some variation in test scores.

Heteroskedasticity
Heteroskedasticity Robust Standard Errors for the OLS Parameter Estimates
White-Huber-Eicker Standard Errors

Interpretation: Since we are using OLS estimates, the t-statistic is still constructed and
interpreted as before, but instead, the robust standard errors are used. The conclusions from the ttests concerning and remain the same.
Gretl Steps:
Model → Ordinary Least Squares → Dependent Variable: testscores, Regressors: const,
homework → Check box for robust standard errors → Ok

Heteroskedasticity Robust F-statistics

Interpretation: The F-test tests the below hypothesis, which is that all the coefficients of the
regressors are equal to 0. The heteroskedasticity robust Wald statistic is a transformation of the
heteroskedasticity robust F-statistic. Because the F-statistic is greater than the critical value, we
have the same inference from the output.

Gretl Steps:
Model → Ordinary Least Squares → Dependent Variable: testscores, Regressors: const,
homework, classsize, hrsofclass → Ok
Wald test: Model output box → Tests → Omit variables → Omit homework, hrsofclass, classsize
→ Select Wald test, based on covariance matrix → Ok

White Test for Heteroskedasticity

Interpretation: The White test is based on the series of squared residuals from the OLS
regression, where the F-statistic is computed from the R-squared of this regression. This
approach uses up degrees of freedom quickly, which is important when your sample size is
small.
The critical value for the F-statistic is 2.8 for a 99% Confidence Interval. Since the F-statistic is
greater than the critical value (and the p-value of the F-statistic is 0), we can reject the null
hypothesis that homoskedasticity holds.

Gretl Steps:
Model → Ordinary Least Squares → Dependent Variable: testscores, Regressors: const,
homework, classsize, hrsofclass → Ok
Tests → Heteroskedas city → White’s Test (squares only)

Interpretation: We can reject the null hypothesis since the F-statistic is greater than 2.8 and the pvalue of the F-statistic equals 0.
Gretl Steps:
Model → Ordinary Least Squares → Dependent Variable: testscores, Regressors: const,
homework, classsize, hrsofclass → Ok
Tests → Heteroskedas city → White’s Test

Alternative to the above model:
Estimate the model:

Interpretation: Use the R-squared from this regression to compute the F-statistic using:

This approach uses fewer degrees of freedom, especially when more independent variables are
added to the original model. The F-statistic is greater than 4.61 (the critical value), so we reject
the null hypothesis that homoskedasticity holds. This can also be shown by the p-value of
3.29 10

Gretl Steps:
Model → Ordinary Least Squares → Dependent Variable: testscores, Regressors: const,
homework, classsize, hrsofclass → Ok → Save → Fitted Values → Name: yhat
Save → Squared residuals → Name: uhatsq
Right click → Define new variable → yhatsq=yhat^2 → Ok
Model → Ordinary Least Squares → Dependent Variable: uhatsq; Regressors: const, yhat, yhatsq

Feasible Generalized Least Squares (FGLS)

Interpretation: h(x) is a function of the explanatory variables that determines the
heteroskedasticity. Since it is hard to find such a function, we can model the function and then
estimate the parameters in this model.
Gretl Steps:
Model → Ordinary Least Squares → Dependent Variable: testscores, Regressors: const,
homework, classsize, hrsofclass → Ok → Save → Squared residuals → Name: uhatsq
Right click → Define new variable →lnuhatsq=ln(uhatsq)
Model → Ordinary Least Squares → Dependent Variable: lnuhatsq, Regressors: const,
homework, classsize, hrsofclass → Ok → Save → Fi ed values → Name: ghat
Right click → Define new variable →hhat=exp(ghat)
Model → Weighted Least Squares → Dependent Variable: testscores, Weight: hhat, Regressors:
const, homework, classsize, hrsofclass → Ok

Ramsey’s Regression Specification Error Test (RESET)
Model Misspecification (Neglected Nonlinearities)

Interpretation: The F-statistic is 66.5292, which is greater than the critical value at a 99%
confidence level, which allows us to reject the null hypothesis. This, in addition to a p-value of
is evidence that the functional form is misspecified.
4.08 10
Gretl Steps:
Model → Ordinary Least Squares → Dependent Variable: testscores, Regressors: const,
homework, classsize, hrsofclass → Ok
Tests → Ramey’s RESET → Squares and cubes → Ok

Test Against Nonnested Alternatives
Mizon and Richard Test

